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                                         Can any of the PDF-XChange products be used to create fillable PDF forms?
                                    


                                    
                                        
                                            Question:


Can any of the PDF-XChange products be used to create fillable PDF forms?


For example, is it possible to create forms that customers can use to fill out their address, credit card details etc and then return to my company?


Answer:


Yes. The PDF-XChange Editor Plus, also included in the PDF XChange Pro bundle can be used for this purpose. PDF-XChange Editor Plus contains the functionality to create the following range of fillable forms. Each feature contains a vast array of options, all of which are listed with greater detail in our product manual here.


All form creation tools are available on the Form tab of the Ribbon interface.


[image: ]


Placing any of these fields is as simple as selecting them and then clicking the location you wish the form field to appear. Alternatively, click and drag to customize the size and dimensions of the field. The Select Fields tool (highlighted above) can be used to select and customize any existing form fields. The basic uses for each will be detailed in this article.(Click the section you wish to know about to expand that portion of the article)


Be sure to review the Managing Fields section at the bottom of this article as well.




Text and Date fields





The Text Field mode is used to add text fields to documents. Text fields are used to denote a space in which users can can enter text, such as their address, or credit card details. Date fields are a custom Text field that prompt the user for a date when clicked. See here for further information.


Once you have placed a text field, you can Customize the format by giving it a background color, changing the text color, and more. All of these options are available in the Format tab, on the right of the ribbon:


[image: ]


After you have customized the field to your liking, you can simply go back to the Hand tool to begin filling the field or send it to a Client to fill in.
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Editing Font Details


To edit font details of a form field, it must be selected with the Select Fields tool, as detailed above. Once that is done, you can see the font details of the field(s) in question in two locations


1. On the Format tab, which appears dynamically after you have selected a field:


[image: ]


2. In the Properties pane, which is available by pressing Ctrl+~ at any time:
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Buttons and Image Fields





The Button mode is used to add action buttons to documents. Buttons allow users to trigger an event/action, such as opening a web link or playing a sound. The Image Field is simply a custom button field which when clicked, prompts the user to select an image and then displays that image within itself. See here for further information.


In this example we will make a button to reset all form fields in a document.


1. After placing a button, you can open the Properties pane from the format tab:
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2. Navigate to the Actions Header and Click the ellipses beside Mouse Down


[image: ]


This action will occur anytime that someone pushes the left mouse button down while it is above this button.


3. Click the Add Dropdown menu, and choose Reset a Form:


Note: If you wish instead to email the form, you can choose Submit a Form, and then prefix your email address with 

mailto: to create a URL to send the form to.
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4. In the resulting window, click Select All, and then click Ok.
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5. This button will now reset all fields in the document to their default values when the button is pressed, allowing users to clear all form fields at once.


**Note that this will not clear out signatures or reset images**








Check Boxes





The Check Box mode is used to add check boxes to documents. Check boxes allow users to make a binary choice between mutually exclusive options, such as yes/no answers. See here for further information.


In this example we will make Check Boxes work with a None of the above option.


1. Place 4 check boxes in your document, beside text, as below.
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2. Use the Select Fields tool to select the fourth option.
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3. Open the Properties pane available from the Format tab.
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4. Navigate to the Actions Header and Click the ellipses beside Mouse Down
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This action will occur anytime that someone pushes the left mouse button down while it is above this button.


5. Click the Add Dropdown menu, and choose "Reset a Form":
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6. In the resulting window, select the other checkboxes, and then click Ok.
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7. This checkbox will now clear out the other three, finally select the other three checkboxes (at the same time), and repeat steps 4 and 5.
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8. After repeating the prior steps, select only the final checkbox to be reset.
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After this is done, you should have checkboxes that function as such:
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Radio Buttons





The Radio Button mode is used to add radio buttons to documents. Radio buttons allow users to choose only one of a predefined set of options, such as when answering multiple choice questions. See here for further information.


Radio buttons function similarly to Checkboxes (above), however when placed in a group only one of them can be selected at a time, and one must be selected at all times within a group.
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1. To manually change the grouping of radio buttons, simply highlight the desired buttons with the Select Fields tool.
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2. Then open the properties pane, from the Format Tab.
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3. Under General in the properties pane, find the Field Name and click on it to edit it (note that if the radio buttons are in different groups, you will need to select and edit them independently).
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4. Change these field names to another name (eg: Radio2) you will then find that the selected radio buttons work independently from the original group.
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Dropdown Menus





The Dropdown mode is used to add dropdown menus to documents. Dropdown menus allow users to select only one value from a list of options contained within a static, multiple line text box, such as a list of nationalities. See here for further information.


1. After Placing the Dropdown Menu, open the Properties Pane from the Format tab.
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2. Under Options in the Properties pane you can customize the Combo Box Items (selection options)
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3. Once this list has been populated, users can use the dropdown menu just as in any other application.
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List Boxes





The List Box mode is used to add a list of choices to documents. List boxes allow users to select one or more items from a list of options contained within a static, multiple line text box, such as a list of months of the year. See here for further information.


List Boxes Function similarly to Dropdown Menus (above), except that they can be configured to allow multiple selections from the Properties Pane.
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Signature fields





The Digital Signature mode is used to add digital signature fields to documents. Digital signature fields allow users to sign documents digitally, which increases security and integrity. See here for further information.


Much like most form fields, placing an empty signature field for later signing is quite simple. Look to the "Form" tab, and click the "signature" tool:
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Then click where you would like the field to be placed (you can also click and drag, to change the size/dimensions of the field)
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Beyond that, signature fields can also be configured with many options, as all fields can be, however the most commonly needed are the security options.


1. Available in the Properties Pane, from the Format Tab.
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2. Navigate to the Signed header.
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3. Notice the options for Mark as read only, and Custom Action.


	Mark as Read-Only will allow you to mark off that the document, including form fields, cannot be edited once a signature has been placed in this field.
	Custom Action will allow you to input a JavaScript or other function to the signature field for custom actions.









Barcodes





The Barcode mode is used to add barcodes to documents. Barcodes translate form data into an encoded pattern that compatible devices can read and archive, which increases security and efficiency. See here for further information. In this example we will be using other fields to determine the barcode value.


1. After placing the barcode, you can open the properties from the Format tab.
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2. This will present you with the Properties pane, navigate down this pane until you see the Value Calculation header.
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Please choose "Encode using Tab Delimited..."


3. Place a new text field and fill it with the text Testing Text, we will use this field for the calculation of the barcode:


[image: ]


4. Select the Barcode once more, and navigate back to the Value Calculation header, This time we will use the "Fields" Value:


	Click the ellipses beside Fields:
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	Check off text 1
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	Click Ok and view the updated barcode
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The Bar code now reflects the text in field 1, and should it be scanned will display that information to most barcode readers, you can use this for websites, and other information passing.








Managing Fields





Naming Fields


Naming a field is a simple process, and can help greatly with form field management later in your document editing.


1. To being, select any form field already in your document and open the Properties Pane, available from the format tab:


[image: ]


2. Under General in the Properties Pane, click on Field Name, and type in a new name.[image: ]


3. the name of the field is now changed, note that these should be changed before making fields reference on another, to avoid issues with the form.

Note: Giving two fields of the same type the same name, will cause them to display the same information. For example, you could name two fields, on different pages, "First name", filling in either would then always cause the other to automatically reflect what was entered.

Defining Tabulation Order


1. To begin, open the Fields Pane (Ctrl+I), located on the View tab, under Panes:
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2. In the resultant window pane, click on options and choose, Order by Pages:
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3. Navigate to the Form tab, and click the Select Fields tool:
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4. Back in the Fields Pane, you can now drag and drop the fields into the desired order:
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Creating Tables





We also offer a "Create multiple copies" tool, which allows you to duplicate a form field into a table-like format.


This tool can be accessed with the select fields tool active, by right clicking on and form field:
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This will open a configuration window which allows you to specify the size of your "table". If you have variation in the size of your rows (or columns) you can draw either of these first, and select all of those fields first, so you can duplicate the group:


[image: ]


After you have set the table to the correct size, simply click OK, and the fields will be created as needed:
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Additional Notes:


Each option has a wide range of customizable options with regard to style and functionality. These options and further information is detailed in the Form Toolbar page of the PDF-XChange Editor user manual, which is available here.


Currently auto detection of form fields is not available at the time of writing this article, it is planned for a future version.


**If you do not have the Pro or Plus version of the Editor these features are still useable, but will place our "Buy now" Watermarks in the corners of the document as they are premium features, You can purchase the Pro or Plus Versions if you wish to license these features.
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                            Need more information? Get in touch.

                    You can contact us by phone, email or our social media accounts — we are here to assist you.
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